MENU

Site-Licensed Software → Using Excel and SPSS files together

Using Excel and SPSS files together

For this explanation of using SPSS and Excel data files, the directory location C:\Work\ProjectFile is being used. Your directory location will be different.

 


Please select the desired information

 


Reading Excel Files into SPSS

The good news is that both Excel and SPSS can read Excel files without any conversion.

Here is an example of opening an Excel file within SPSS.  You start SPSS and select the Open and Data options from within the File menu:

 

Change the "Look in:" window until it points to the desired directory location and then press the down arrow on the "Files of Type:" window until you can select "Excel (*.xls)".

You will be given a list of all Excel files within the directory.  Select the desired spreadsheet file.  In this example that file is named "Fall1999.xls".

An "Opening Excel Data Source" window comes up next:

Within this screen you indicate to SPSS that you will use the values within the first row as the variables names for the SPSS dataset.  You also indicate that you will be reading the entire spreadsheet.  This is what is meant by "PRINT1 [A1:G214]".

Once you press the OK button, a window like the following will come up:

This should contain exactly the same values as the Excel spreadsheet.  To get more detailed information on the variables, press the "Variable View" tab.  Here is an example of this window:

These variable names and other information were set within the Excel file.

Before analyzing these data values with SPSS, it is recommended that you save the converted file as a SPSS dataset.  Select the "Save" option from the File menu.  Here is an example:

For future use of these data, you will open the "From-Excel.Sav" file within SPSS.

Back to the top

 


Reading SPSS file into Excel

The news is not so good in the opposite direction - SPSS to Excel. The SPSS dataset must be converted to an Excel format.

Start by opening a SPSS dataset.  You start SPSS and select the Open and Data options from within the File menu:

Change the "Look in:" window until it points to the desired directory location.  You should see a list of SPSS datasets (*.sav) files within that directory.  We will be opening the file named "Winter2000.sav".

You see a window which looks something like the following:

Now it is time to convert the file to Excel.  Select the File menu again, but this time select the "Save As" option.  If necessary, change the "Look in:" window until it points to the desired directory location and then press the down arrow on the "Save as type:" window so that you can select the "Excel (*.xls)" choice.

In the "File name:" bar give a new filename.  For this example, the name "From-SPSS" is typed into that bar.

Information about this conversion is displayed within the "SPSS Output" window:

That's all there is to moving SPSS datasets to Excel.  Here is what this dataset looks like within Excel:

Notice the "#NULL!" value given in cells D2 and G2. These are an examples of missing values. Excel should see those values in much the same way as SPSS.

Back to the top

 


For further information please contact Information Services' software acquisition expert via email at umkc-software@umkc.edu or at 816.235.8810.

  



Was this page helpful to you? or
Do you like the new website? or