Web Editing Basics 2: Reference
We will be using the sample pages as a reference point for this training. They can be found on the Web Policy site:
http://www.umkc.edu/web-policy/downloads.asp
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ANATOMY OF A PAGE
UMKC Header
The standard university header identifies that the visitor is still on a UMKC Web site and provides consistent
navigation back to other UMKC Web sites.

Web site title bar
The Web site title bar should appear underneath the header. The site name should not change from page to page.

Sidebar
The site navigation for UMKC Web
sites appears in a section we’ve
labeled the “sidebar.” This
navigation is aligned left on the
page in order to facilitate
convenient navigation for all screen
resolutions and create a consistent
user experience across Web sites.

Content
Content is the most important part
of a Web site because without it
the site has no reason to exist.
Content can mean many different
things, text, images, video, and it
can be organized in a multitude of
ways, such as lists, tables and
accordions.
Breadcrumbs: Using
breadcrumbs on your site is good
practice, especially if you have a
large site. They provide a path
back to the top level of your site
and help users understand site
organization.
Headline: This text should clearly
identify the page and should match
the page title.

Resources
This area of the page can be used
for related links or documents,
contact information and links to
external resources such as
documents or forms. Listing or
repeating this information allows
users to quickly find what they are
looking for without reading
paragraphs of information.

UMKC Footer
The university footer includes important links for accessibility as well as copyright information. The footer also
includes a tracking tag used to traffic data through Google Analytics.
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CREATING A NEW PAGE:

1. Determine the purpose of the page.
Before you create a new page on your site, you should always do a quick review of why you are creating the
page and whether or not it is necessary. Answering a few questions first will help you decide how users will
navigate to this information and how the information itself should be organized.
a. Does this page add something of value to the Web site?
If not, then maybe the information would be better suited as a new section on an existing page.
b. Does the information on this page belong with any other page on the site?
Maybe the page should be part of a rollover menu under another subject or a related link on another page.
c. Does this page serve a temporary purpose?
If the content will only be needed on a short-term basis, you do not want to add the new page to your site’s
main navigation.
d. Should this page be a downloadable document or should it be split between multiple pages?
Too much scrolling can cause eye fatigue, and few visitors will be willing to read that much text on the
screen. You can limit the amount of content a visitor sees at a time by using accordions, or if you think it’s
likely a visitor would want to print the page to read it or keep it in their files, then you should turn the page
into a downloadable PDF.

2. Open a page that is similar in layout to the one you want to create.
Connect to the development server. Answer the following questions to determine what kind of layout you need.
a. Is the content all text? Is it straightforward and less than two pages long?
Find a layout that has as few extra elements as possible to minimize the number of things you have to
delete. If you don’t have a layout like this in your site, you can download an example page here:
http://www.umkc.edu/web-training/examples/simple.asp
b. Does the content include a chart, or data from a spreadsheet?
Use a layout that includes tables. If you don’t have a layout like this in your site, you can download an
example page here: http://www.umkc.edu/web-training/examples/table.asp
c. Is the text document more than two pages long? Are there multiple divisions within the content?
Consider using a layout that includes accordions. If you don’t have a layout like this in your site, you can
download an example page here: http://www.umkc.edu/web-training/examples/accordion.asp

3. Select File > Save As.
Type a new name for the page and save it in a location that makes sense in the overall organization of the site,
keeping in mind the purpose you determined in step one.
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4. Update Title and Meta Tags
These items can impact your search engine ranking, but are often overlooked. It’s a good idea to update them
right away so you don’t forget. Click on the Split button at the bottom of the page window to split the window
between code and design view. Scroll to the very top of the code and look for the following:

Title should ideally include UMKC’s name, the name of the Web site and the title of the page.
Keywords can be phrases and are separated by a comma. Fifteen to twenty keywords is a good number for
each page.
Description should be written in sentence format. Search engines will often display part of this in their results.

5. Update Breadcrumbs and Headline.
You will find both of these items in design view at the top of the content section.
Breadcrumbs
Not all pages will have this, but they should be
located near the top of the page above the main
content. Breadcrumbs help a visitor to know
where they are in the site at all times.
Headline
Appears at the top of the content and should use an h1 tag.

6. Insert content.
By answering the questions in Step 2, you should be using a layout that matches your content.
Copy your text into the content <div> and divide it into paragraphs with <p> tags. Separating sections with
headlines and subheads and use bullets and numbered lists where necessary. Keep in mind that people do not
read on the Internet. They scan. Because of this, it’s a good idea to avoid long paragraphs of text and try to
break information out into smaller, digestible bits.
The sample pages provide several other areas for customizable content. One area is a feature section
provided under the left-hand navigation, often referred to as the sidebar. This block can be used for many
things, including highlighting an upcoming event, a quote related to the page’s content or a news item.
Another area is the resources column to the right of the content
column. In code view, this <div> usually appears after the content
<div>. This section allows all the same formatting that is available
in the content column, but remember that it is narrow, so tables
and accordions probably won’t fit here. Use this area for contact
information, links that connect to pages outside of your Web site
and quick links to forms and documents.
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TIP: paste text
When copying from another document,
use Paste Text in Sharepoint to avoid
creating extra styles that will need to
be deleted later. Select Edit > Paste
Text. A dialog box will pop up. Choose
plain text from the list of options.

7. Test the new page in a browser.
After you have saved your new page, open Internet Explorer or your browser of choice. In the address bar, type
the path to your page, making sure to replace “www” with “dev.” For example, if the new page is located inside
the web-training site and is named “new.asp,” then the path would be: http://dev.umkc.edu/webtraining/new.asp.
Check to make sure that everything on the page is functioning and make any necessary edits. If everything is
working, you’re ready to move on to step 8.

8. Add the new page to site navigation.
This will probably not be visible on the page because navigation is usually saved as an include file. Look for a
file named “sidebar” or “navigation” in your Folder List.
Note: You can find the name of the include file by clicking the sidebar and looking at the include in code view.

TERMINOLOGY:

The side navigation is often built as an unordered list. Each bullet is an item
in the menu, and the indented bullets are rollover menu items. Add a new
bullet for your page and create a hyperlink to the new page. Depending on
how your site is organized, you may need to use absolute links on the
sidebar. Click on the Split button at the bottom of the page window to split
the window between code and design view. Look at the code to see how the
links are built. If they start with “http” then you need to use absolute links.
After you’ve updated the navigation, it’s important that you check the site
again in a browser to make sure that the link is working.

Absolute link: A
hyperlink which specifies
the full path to the page
(http://www.website.com).
Relative link: A hyperlink
that specifies the folder
needed to traverse to the
page. If a Web page is
found in folder A within
folder B, then the path to
the page is B/A/page.

9. Update the production server.
Once you’ve tested the page and the sidebar, open a new Sharepoint window and connect to the production
server (www.umkc.edu). Copy the new page, any associated image files or documents and the sidebar file,
then paste them onto the production server.

DELETING A PAGE:

1. Archive the page to your backup.
Select the page in the folder list, then select File > Export > File from the menu. Choose a place to save the
archived page on your hard drive or file server.

2. On the development server, right click on page and select Delete.
3. Clean up.
Remove page from site navigation and delete any references to the page throughout the site. Then, delete any
images or documents related to this page. Make sure that you do these steps on both the development and
production server to make sure your site stays clean and organized in both places.
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MODIFYING TABLES:
Tables have their own nomenclature, but they function just like other HTML tags. Each tag comes in a pair, an
opening and a closing tag. Styles can be applied to an entire table or an individual cell. To select an entire cell, click
in the cell and then click on the highlighted <td> tag in the Tag Navigator.

 Modify cellpadding, cellspacing or border properties:







TIP: 0 means nothing, but

select table, right click and select Table properties.
nothing means something
Add cells, rows or columns: right click on a cell, select Insert
and choose from the options.
If an attribute value is empty, that
Delete a cell, row or column: right click on a cell, select
does not mean it is set at 0.
Delete, then choose from the options.
Instead, it means that the attribute
will follow browser defaults when
Merge or split cells: right click on a cell and select Modify,
the page is displayed. Defaults are
then choose from the options.
rarely 0, so if you want a table that
Change the width of columns: click on the space between
has no space between the cells,
cells (cursor should turn into a two-headed arrow) and drag.
you need to set cellpadding and
Keep in mind that the table is built on a column grid, and you
cellspacing to 0.
cannot change the width of a single cell without changing the
width of all the cells in that column.
Change the height of rows: This cannot be done without using CSS because the cells will
.
automatically expand to fit the content inside of them.

Note: While tables should be used primarily for displaying data, you will find when editing pages that this tool has
been used for everything from organizing content to building overall page layout. Before CSS was available, tables
were one of the few tools Web developers had available for controlling the design of a page.

SHAREPOINT DESIGNER TIPS:
Tag Navigator:
At the top of your page, you will see
something that looks like the picture on
the right.
The tag navigator helps you keep track
of where you are in a page and what
exactly you have selected. Click
anywhere in a page, and the path on
this bar will change, showing you what
tags exist around that particular spot. If
you click on a tag in the bar, it will select that entire tag in both design view and code view.
Changing views:
At the top of your page, you will see something that looks like this:
Keep your view set on Split view as much
as you can. This will allow you to see both
code view and design view at the same
time. While you might not be able to use the
code much yet, keeping it visible will help
you to understand how changes in Design
view change the code.
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HTML CODE MADE EASY
Most HTML tags have two parts, an opening tag and closing tag. For example, a div would look like this:
<div>content</div>. Tags can be nested inside of each other, but the order works like an onion. The first tag
opened should be the last tag closed.

BASIC PAGE STRUCTURE:
div

This tag is used to define sections of a Web page that
can be manipulated in various ways. The <div> tag can contain
nearly any other tag, but cannot appear inside other tags.

p

This tag is used to create paragraphs.

a

This tag is used for hyperlinks and anchors and must
include an href attribute. It does not have a closing tag.

img

This tag places an image on the page, must include a
src attribute pointing to the image file, and should include
height, width and alt attributes. It does not have a closing tag.

h1, h2, h3, h4, h5, h6
These tags are used for headlines. In general, h1 is used for the
most important headline on the page and h6 for the least
important.

<html>
<head>
This is where you will find your page title,
meta tags (keywords, description) and
imported files (CSS, javascript, etc). This
section is not visible in the browser
unless you view the source code.
</head>
<body>
This is where all the content of your page
goes. Layout, all text, images and links
will go in this section.
</body>
</html>

id, class

These attributes are used to label tags and can be used with CSS to apply a style or modify the
appearance and layout of any tag. Ids should only be used once per page, but classes can be used as many times
as needed on a single page.

ul, ol, li
<ul>
<li>Item one</li>
<li>Item two</li>
<li>Item three</li>
</ul>

These tags are used for creating lists. If you want
a list of bullets, you would use a <ul> tag around
the entire section, and <li> tags between each
bulleted item. You could do the same thing with a
numbered list, or ordered list, by using the <ol>

tag instead.

table

Defines the beginning and end of the
table. The opening tag should have a value for width,
border, cellpadding (margin within each cell) and
cellspacing (margin between cells).

tr, th, td

Table row, table header and table
division. Tables are organized by rows, not columns. If
you have two columns, you will have two table divisions
within the table row.

QUESTIONS
If you have additional questions about any of these topics, plan to attend a question session after another one of
these trainings. You can find the training schedule on http://www.umkc.edu/web-training/
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